We have released an updated Airtame application 5.0.0 for Chromebooks. This update provides improved performance of streaming to Airtame 2 devices. However, you will no longer be able to use this application version to stream to Airtame 1 devices or any Airtame devices with a firmware version lower than 4.4.0. In order to ensure that you can continue to receive an uninterrupted experience on your Airtame 1 devices, we have maintained backward compatibility by publishing a legacy version of the Airtame application.

In the Chrome Web Store, you will find two Airtame applications:

  • Search for “Airtame”: the newest application version that is used for streaming to Airtame 2 devices on Firmware version 4.4.0 or higher.

  • Search for “Airtame Legacy”: the legacy application version that is used for streaming to Airtame 1 devices or any device with a Firmware version lower than 4.4.0.

You can also access the applications directly by following the links below:

Both applications can be installed on a Chromebook alongside each other for users with mixed device types (Airtame 1 and Airtame 2) in their environments.

Please note that the new Airtame application brings significant performance improvements and is recommended for use in all cases where backward compatibility is not required. The legacy Airtame Legacy application can theoretically stream to any Airtame device or firmware version but is recommended to be used only in the aforementioned cases.

If you wish to upgrade your Airtame 1 device, please contact your account manager.


Do you have any questions?

You can write to us using the blue chat box in the lower right-hand corner or send an email to [email protected] and we will be here to assist you.


If you are facing technical issues, remember to include Airtame device logs in your message.

for product updates to stay posted on future features.

Did this answer your question?